AnsweredAssumed Answered

GainSpan 1011M MQX MCF52259 integration questions

Question asked by Angelo Quattrociocchi on Mar 18, 2013
Latest reply on Mar 19, 2013 by David E Seymour

I'm using the GS1011 WiFi module in a custom board and am having some trouble getting the hardware interface working.  On a MCF52259 tower setup it works fine (although so far I only tried it in SPI mode), but a custom board which is based on the same design has problems.  I'm trying to get either SPI or UART working.

 

UART:

I noticed the messages coming from the module were at 9600 baud, while the messages going to the module from the 52259 were at 115200.  I changed the configuration in the BSP so they would communicate properly at 9600 (although I would prefer 115200), so I'm not sure if this is a bug in the wifi patch or there is some other reason.  Once they were communicating however, when I tried web provisioning, after sending the username, password, SSID, IP, etc. to the module, it responds with "ERROR: INVALID INPUT".  Any idea what this means?

 

SPI:

When configured for SPI, I see the data out, clock, and CS coming from the 52259, but the module seems to ignore it (there is no data in or interrupt output from the module).  So the program stops right away when trying to get the module version and MAC. 

 

This is a off-the-shelf module I purchased for this board and didn't do any firmware changes or any other configuration.  Do I need to in order for it to behave like the one on the tower?

 

Thanks

Outcomes