AnsweredAssumed Answered

iMX6Q + Sabre Board: Need help with booting the example found in the SDK package

Question asked by yuni1988 on Mar 12, 2013
Branched to a new discussion

I compiled the smp_primes example (found in the SDK package) as it was written in the README.pdf, and succesfully got the elf file. Package is attached.

 

Now I'm trying to download the file and run the app. I did the initialisation (init script for i.MX6Q DDR3). I'm trying to download it via JTAG.

It looks like download is successful, but when I run it, it immediately falls to undefined address hook and loops somewhere in ROM.

 

The linker file specified the app to be in DDR and OCRAM:

    OCRAM (rwx) : ORIGIN = 0x00900000, LENGTH = 256K

    DDR (rwx) : ORIGIN = 0x10000000, LENGTH = 1024M

 

but the app never gets there. I tried accessing the locations manually and it looks like the initialization was OK, because it lets me change values.  I'm thinking I didn't set the boot switches correctly, but I can't make it out from the documentation how I should set them for this. I went with trial and error, but no luck.

 

Anyone has any ideas?

 

Original Attachment has been moved to: samples.tgz

Outcomes