AnsweredAssumed Answered

Can't establish an ethernet connection between mqx and windows

Question asked by projektecarus on Mar 8, 2013
Latest reply on Mar 20, 2013 by Monica Arvizu

Hey,

 

I am trying to establish an ethernet connection between my windows 7 pc and a twrk60f120m running MQX 3.8. I am using CodeWarrior 10.3.

At first I was trying to do it on my own, using the RTCS user guide. I wasn't able to get it to work, so I tried the example projects coming with MQX. Unfortunately, I had no success. I also tried changing my setup, i.e. using another pc/cable, changing my firewall/port settings and so on. Still no ethernet connection, so I need some help now.

 

Let's take telnet-to-serial demo project as an example. I am fairly sure that everything is fine until the program reaches the socket accept line:

 

sock = accept(listensock, NULL, NULL);

 

At this point, nothing happens. If I understand it correctly MQX is waiting for an incoming connection now. According to the readme I am supposed to use hyperterminal to send one. I do so, I can detect the outgoing request at my pc's ethernet device, but there is absolutely no reaction on the other side. If it is still doing anything it keeps waiting for a connection. Any ideas?


Thanks in advance.

Outcomes