AnsweredAssumed Answered

Alpha blending question

Question asked by KAMIL KOMPA on Mar 1, 2013
Latest reply on Mar 4, 2013 by KAMIL KOMPA

Hello,

 

I have an application which uses GLES (EGL-fb based), GTK and Gstreamer. For video playing the mfw_v4lsink is used. The application works properly under Ubuntu Linux. I need to use additional kernel drivers. Thus, I have recompiled the system by using LTIB. On the new system, alpha blending doesn't work. I use alpha blending to show GTK widgets and GLES window along with the movie. I have tried several configurations of the kernel with no success. Also, I have used the configuration which is included in the /boot directory of the Ubuntu system, but the application doesn't work properly on the compiled kernel. The video is properly scaled, but the edges are black (background should be visible). Also, if I run the gstreamer from rs232 console, the video is playing ok, but when I stop the streamer, the screen is black. And if i copy uImage from Ubuntu to my LTIB system, everything works fine. Any clues what's wrong?

 

Regards,

Kamil

Outcomes