samsaprunoff

K60 Debugging Problem with new parts

Discussion created by samsaprunoff on Feb 21, 2013
Latest reply on Feb 22, 2013 by samsaprunoff

Good day All,

 

Just a heads up to those that are just starting to use/debug a K60 design... hopefully this info will save you a number of hours of head scratching...

 

It appears that the K60 needs to be initially erased and programmed before in circuit firmware debugging will work. I spent a number of hours trying to figure out what was happening with my custom K60 design and went so far as to remove the chip and install another one and found that the problem remained.  It was by chance that I tried attempted to erase the chip and discovered that this function would work... I then tried to debug, but it was a still a no go.  I then erased and programmed the chip and when I did this I was able to debug every time afterwards.  I submitted a support ticket to Freescale and they thought it was a Codewarrior issue.  I was pretty sure it wasn't, as the problem was completely replicable on new parts only... As it turns out I was speaking to a colleague today, who works for a large US firm, and he said that they had exactly the same problem... and their firmware group uses IAR for their toolset so CW is not the problem. My guess is that there is some existing factory test code is present within the K60 and this code was not erased before going into general distribution.

 

Anyway, if you are unable to debug your new K60 try to erase/reprogram the device, as this may get you going and save you a bunch of wasted debug time...

 

Cheers,


Sam

Outcomes