AnsweredAssumed Answered

CW10.3 wont program MRAM at all via my Cyclone MAX (Ethernet or USB)

Question asked by Carl Norman on Jan 15, 2013
Latest reply on Mar 27, 2013 by Zahar Raskin

Hi Guys,

 

Firstly, I have been using MQX in production since MQX3.0, so I have a fair idea about the tool chain and how it all works. I also have two programmers, two computers and two installations doing exactly the same thing. This is our first week back after a long Christmas break, so I hope its just something we are doing wrong.

 

I cant get the MRAM program from the 2 x cyclone's or 1 x Multilink on 2 x computers (all flash programming, and all software work, software can even write / read from MRAM, just not the programmers). The thing wont work with MRAM debug for hello world example or my production code, and no writing variables in there via way of manually putting them in MRAM space, or, using the linker to put code in the MRAM space. Anything in the S19 that is in MRAM space 100% does not get written, ever. I know 100% this all should work as I have quite a lot of experience.

 

Right now I have production units that need to be shipped and am now madly trying to roll back to CW10.2 which I know works.

 

Any help? please? (I have a service request pointed at this thread)

 

Details:

Cyclone MAX Updated software to 7.72-6.0, tried Ethernet and USB

Multilink same result

MQX3.7

CW10.3 current version that was just released

52259evb (52259 evaluation board with MRAM)

Windows 7

Outcomes