AnsweredAssumed Answered

K20 will not program

Question asked by greg on Jan 3, 2013
Latest reply on Jan 4, 2013 by greg

I'm working on a project that was first prototyped on a tower board and I now have the first revision of the hardware back.  I'm using the K20DX128VFM5. I followed the schematic from the tower board for the power and JTAG lines.  The first try of programming the chip did not work.  The debugger would not connect to the chip getting the error message: "Can't connect. The Debugger can not connect to the P&E device(ARM GDI Protocol Adapter)".  I've check the power rails to make sure nothing was shorted. I probed the reset line with a scope and saw it oscillating.  I've been looking at every post on here about oscillating reset pins. The chip is brand new and never programmed so I understand why the reset occurs, either illegal address fetch or the watchdog is resetting the chip.  Here are some things I've tried:

 

-Hold the reset low while applying power to the chip

-Hold NMI pin high while applying power to make sure it is not in EZ programming mode

-Hold NMI pin low while applying power to force it into EZ programming mode

 

I've also probed the JTAG lines.  The clock and data line to the chip look good, clocks pulsing and data moving. However, the data line from the chip to the programmer looks awful.  It's usually low and the data doesn't quite make it to 1V on the scope when it's pulsing. 

 

I then thought it may be the programmer or IDE.  I've tried CW 10.2, CW 10.3 and Keil.  I've also tried using a P&E universal multilink FX and a ULINK2.  None of them have worked.  I've read some about using a J-LINK to unlock the flash for new chips, but I don't have a J-LINK.  Is there something special that needs to be done for the first time this chip is programmed?  I done a lot of projects with many other micros but this is the first one with a cortex and I have never had this much trouble programming the chip.  Any help would be appreciated.

 

Thanks,

Greg

Outcomes