AnsweredAssumed Answered

LTIB Build Error - imx-lib

Question asked by abdulrazak on Dec 4, 2012
Latest reply on Feb 1, 2013 by brunoceldran
Branched to a new discussion

Hi All,

 

I am running in to a issue while building ltib for i.mx35. Please help me solve this issue.

Also has some one built gstreamer package for i.mx35. If yes, please let me know the steps.

Below is the log.

 

Processing: imx-lib

=====================

Build path taken because: directory build, build key set, no prebuilt rpm,

 

rpmbuild --dbpath /home/dt-blr-04440/ltib/rootfs//var/lib/rpm --target arm --define '_unpackaged_files_terminate_build 0' --define '_target_cpu arm' --define '__strip strip' --define '_topdir /home/dt-blr-04440/ltib/rpm' --define '_prefix /usr' --define '_tmppath /home/dt-blr-04440/ltib/tmp' --define '_rpmdir /home/dt-blr-04440/ltib/rpm/RPMS'  --define '_mandir /usr/share/man' --define '_sysconfdir /etc' --define '_localstatedir /var' -bi --short-circuit  /home/dt-blr-04440/ltib/dist/lfs-5.1/mxc-misc/imx-lib.spec

Building target platforms: arm

Building for target arm

Executing(%install): /bin/sh -e /home/dt-blr-04440/ltib/tmp/rpm-tmp.17553

+ umask 022

+ cd /home/dt-blr-04440/ltib/rpm/BUILD

+ cd imx-lib-10.04.01

+ [ -z  ]

+ KERNELDIR=/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/../linux

+ KBUILD_OUTPUT=/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/../linux

+ rm -rf /home/dt-blr-04440/ltib/tmp/imx-lib

+ [ -n  ]

+ echo imx35_3stack

+ awk {print toupper($0)}

+ PLATFORM_UPPER=IMX35_3STACK

+ make PLATFORM=IMX35_3STACK DEST_DIR=/home/dt-blr-04440/ltib/tmp/imx-lib//opt/freescale/rootfs/arm install

make -C ipu install

make -C screenlayer install

make[1]: Entering directory `/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/ipu'

make -C sim install

Not support platform, will not complile

make[1]: Leaving directory `/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/ipu'

make -C vpu install

make[1]: Entering directory `/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/screenlayer'

make[1]: Entering directory `/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/sim'

make[1]: Nothing to be done for `install'.

make[1]: Leaving directory `/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/sim'

Not support platform, will not complile

make[1]: Leaving directory `/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/screenlayer'

make[1]: Entering directory `/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/vpu'

make[1]: Nothing to be done for `install'.

make[1]: Leaving directory `/home/dt-blr-04440/ltib/rpm/BUILD/imx-lib-10.04.01/vpu'

+ exit 0

Processing files: imx-lib-10.04.01-1

error: File not found by glob: /home/dt-blr-04440/ltib/tmp/imx-lib/opt/freescale/rootfs/arm/*

 

 

RPM build errors:

    File not found by glob: /home/dt-blr-04440/ltib/tmp/imx-lib/opt/freescale/rootfs/arm/*

Build time for imx-lib: 0 seconds

 

Failed building imx-lib

 

 

f_buildrpms() returned an error, exiting

traceback:

main:560

 

 

Started: Wed Dec  5 09:20:10 2012

Ended:   Wed Dec  5 09:26:32 2012

Elapsed: 382 seconds

 

These packages failed to build:

imx-lib

 

Build Failed

 


Outcomes