AnsweredAssumed Answered

How to patch r13.4-ga to Android 4.0.4

Question asked by marcolin on Nov 29, 2012
Latest reply on Dec 4, 2012 by jimmychan
Branched to a new discussion

Hello:

    I will developer Android with Sbarelite 6x board .The first ,I'll compiler Android source code with it. when I doing the section 5.1 "Patch Code for i.MX",

with the "c_patch /opt/imx-android-r13.4-ga/code/r13.4-ga imx_r13.4-ga" command,there are many error!How can I do?The error following:

Verify patches ...

Verify patch for build

error: patch failed: core/Makefile:784

error: core/Makefile: patch does not apply

error: patch failed: core/main.mk:756

error: core/main.mk: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/build.git to /home/linmao/imx6/myandroid/codeaurora/build. Stop

Verify patch for bionic

error: patch failed: libc/kernel/common/linux/ion.h:265

error: libc/kernel/common/linux/ion.h: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/bionic.git to /home/linmao/imx6/myandroid/codeaurora/bionic. Stop

Verify patch for bootable/recovery

error: patch failed: default_recovery_ui.c:38

error: default_recovery_ui.c: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/bootable/recovery.git to /home/linmao/imx6/myandroid/codeaurora/bootable/recovery. Stop

Verify patch for external/alsa-lib

warning: Android.mk has type 100644, expected 100755

Verify patch for external/alsa-utils

Verify patch for external/bluetooth/bluez

error: patch failed: tools/hciattach.c:1306

error: tools/hciattach.c: patch does not apply

error: patch failed: tools/hciattach.h:53

error: tools/hciattach.h: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/external/bluetooth/bluez.git to /home/linmao/imx6/myandroid/codeaurora/external/bluetooth/bluez. Stop

Verify patch for external/chromium

Verify patch for external/fsck_msdos

Verify patch for external/ppp

error: android/Android.mk: ?????????

error: patch failed: pppd/Android.mk:36

error: pppd/Android.mk: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/external/ppp.git to /home/linmao/imx6/myandroid/codeaurora/external/ppp. Stop

Verify patch for external/svox

Verify patch for external/tinyalsa

error: patch failed: include/tinyalsa/asoundlib.h:154

error: include/tinyalsa/asoundlib.h: patch does not apply

error: patch failed: pcm.c:794

error: pcm.c: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/external/tinyalsa.git to /home/linmao/imx6/myandroid/codeaurora/external/tinyalsa. Stop

Verify patch for external/webkit

warning: Source/WebCore/platform/graphics/ImageBuffer.h has type 100644, expected 100755

error: patch failed: Source/WebCore/platform/graphics/ImageBuffer.h:79

error: Source/WebCore/platform/graphics/ImageBuffer.h: patch does not apply

warning: Source/WebCore/platform/graphics/android/ImageBufferAndroid.cpp has type 100644, expected 100755

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/external/webkit.git to /home/linmao/imx6/myandroid/codeaurora/external/webkit. Stop

Verify patch for external/wpa_supplicant_8

error: patch failed: src/drivers/driver.h:704

error: src/drivers/driver.h: patch does not apply

error: patch failed: wpa_supplicant/.config:397

error: wpa_supplicant/.config: patch does not apply

error: patch failed: wpa_supplicant/Android.mk:1442

error: wpa_supplicant/Android.mk: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/external/wpa_supplicant_8.git to /home/linmao/imx6/myandroid/codeaurora/external/wpa_supplicant_8. Stop

Verify patch for frameworks/base

error: patch failed: core/jni/android_os_Power.cpp:59

error: core/jni/android_os_Power.cpp: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/frameworks/base.git to /home/linmao/imx6/myandroid/codeaurora/frameworks/base. Stop

Verify patch for frameworks/media/libvideoeditor

Verify patch for hardware/alsa_sound

warning: AudioStreamInALSA.cpp has type 100644, expected 100755

warning: AudioHardwareALSA.cpp has type 100644, expected 100755

error: patch failed: Android.mk:38

error: Android.mk: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/hardware/alsa_sound.git to /home/linmao/imx6/myandroid/codeaurora/hardware/alsa_sound. Stop

Verify patch for hardware/libhardware

error: modules/sensors/Android.mk: ?????????

error: modules/sensors/sensor.c: ?????????

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/hardware/libhardware.git to /home/linmao/imx6/myandroid/codeaurora/hardware/libhardware. Stop

Verify patch for hardware/libhardware_legacy

error: patch failed: wifi/Android.mk:28

error: wifi/Android.mk: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/hardware/libhardware_legacy.git to /home/linmao/imx6/myandroid/codeaurora/hardware/libhardware_legacy. Stop

Verify patch for hardware/ril

error: patch failed: reference-ril/reference-ril.c:43

error: reference-ril/reference-ril.c: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/hardware/ril.git to /home/linmao/imx6/myandroid/codeaurora/hardware/ril. Stop

Verify patch for libcore

Verify patch for packages/apps/Browser

Verify patch for packages/apps/Camera

error: patch failed: src/com/android/camera/panorama/PanoramaActivity.java:443

error: src/com/android/camera/panorama/PanoramaActivity.java: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/packages/apps/Camera.git to /home/linmao/imx6/myandroid/codeaurora/packages/apps/Camera. Stop

Verify patch for packages/apps/Gallery

Verify patch for packages/apps/Gallery2

error: patch failed: AndroidManifest.xml:59

error: AndroidManifest.xml: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/packages/apps/Gallery2.git to /home/linmao/imx6/myandroid/codeaurora/packages/apps/Gallery2. Stop

Verify patch for packages/apps/Launcher2

Verify patch for packages/apps/Music

Verify patch for packages/apps/Settings

error: src/com/android/settings/PluggableDisplaySettings.java: ?????????

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/packages/apps/Settings.git to /home/linmao/imx6/myandroid/codeaurora/packages/apps/Settings. Stop

Verify patch for packages/apps/SoundRecorder

Verify patch for packages/apps/VideoEditor

Verify patch for packages/inputmethods/PinyinIME

Verify patch for packages/providers/MediaProvider

Verify patch for packages/wallpapers/Basic

Verify patch for packages/wallpapers/MagicSmoke

Verify patch for prebuilt

Verify patch for system/core

error: ts_calibrator/Android.mk: ?????????

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/system/core.git to /home/linmao/imx6/myandroid/codeaurora/system/core. Stop

Verify patch for system/extras

Verify patch for system/netd

error: patch failed: SoftapController.cpp:77

error: SoftapController.cpp: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/system/netd.git to /home/linmao/imx6/myandroid/codeaurora/system/netd. Stop

Verify patch for system/vold

error: patch failed: DirectVolume.h:27

error: DirectVolume.h: patch does not apply

Error! Can't patch from /home/linmao/imx6/imx-android-r13.4-ga/code/r13.4-ga/platform/system/vold.git to /home/linmao/imx6/myandroid/codeaurora/system/vold. Stop

 

 

Outcomes