AnsweredAssumed Answered

Processor expert not available when .cpp files are used ?

Question asked by Karthik Sukumar on Nov 21, 2012
Latest reply on Nov 22, 2012 by Erich Styger

Hi guys,

 

I tried making a project with .c,.cpp and .asm files and the processor expert would not be included in the project! Is there a way to add the processor expert files into it?

 

I tried file -> New -> other -> processor expert -> enable processor expert for existing C project and it successfully added Device initialization component to the project but when I compiled I got the following errors

 

DescriptionResourcePathLocationType
C1834 Indirection applied to non-pointerMCUinit.c/DZ128_work/Sourcesline 154C/C++ Problem
C2450 Expected:  . * + - & ! ~ ++ -- -> [ ( :: IDENT CONSTANT STRING sizeof __alignof__ __va_sizeof__ __va_arg_type__ delete new throwMCUinit.c/DZ128_work/Sourcesline 154C/C++ Problem
C2801 ')' missingMCUinit.c/DZ128_work/Sourcesline 154C/C++ Problem
mingw32-make: *** [Sources/MCUinit_c.obj] Error 1DZ128_workC/C++ Problem

 

Please advise

Regards

K

Outcomes