AnsweredAssumed Answered

OpenSDA Flasher works, but Debugger does not work

Question asked by Antonio Quevedo on Nov 14, 2012
Latest reply on May 20, 2013 by Antonio Quevedo

I have a Freescale FRDM board, with a KL25 target processor and OpenSDA interface. In the beginning it was working fine, but now the DEBUG-APP_Pemicro_v102.SDA app is not working, although the MSD-FRDM-KL25Z_Pemicro_v107.SDA works OK.

 

What I mean is, I can load the flasher (MSD) app to load a SREC file, and the board will accept it (the program will load and start running). However, if I load the debugger (DEBUG) app and try to debug a project (I tried that with a project that was previously working fine), I get an error window (file OpenSDAError.jpg attached), and then when I click OK I get a window asking me to select the connection I want to use. If I retry connection, I get another error (file OpenSDAError2.jpg attached). I am using CodeWarrior 10.3 Beta.

 

When I plug the board with the debugger app previously loaded, I can see the CDC and debugger devices in my hardware manager (windows XP 32-bits), and the bootloader mode accepts the app files. I tried to reinstall the drivers, but I don't know what can be going wrong.

 

Any ideas?

 

Attachments

Outcomes