AnsweredAssumed Answered

CONFIGURE IP ADDRESS FOR LIVE STREAMING FROM SD CARD BOOT

Question asked by shanmugamsundar on Nov 4, 2012
Latest reply on Nov 7, 2012 by jimmychan
Branched to a new discussion

HI ALL,

 

I am using imx535 qsb.we interface a camera streaming application in the qsb board for that i have a setup of imx board and a host linux pc. i had booted the board from tftpboot using lan and also i live streamed the video using lan. Now i changed to booting setup to SD card the board gets booted i want to live streamed the video when i set the ip address in the gstreamer command the capture process takes place but in the host pc i can't see the gst-launch window. can any one help me .

 

COMMAND GIVEN FOR STREAMING:

 

gst-launch  mfw_v4lsrc fps-n=30 capture-width=1280 capture-height=720 capture-mode=4  ! queue ! mfw_vpuencoder codec-type=0 ! rtpmp4vpay ! udpsink host=192.168.0.50 port=5000 ----> THIS IN SERIAL PORT

 

 

 

gst-launch udpsrc port=5000 caps ="application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)MP4V-ES, profile-level-id=(string)6, config=(string)000001b006000001b59113000001000000012000c888800f528045a14103, payload=(int)96, ssrc=(guint)424830278, clock-base=(guint)2874253685, seqnum-base=(guint)43950" ! gstrtpjitterbuffer ! rtpmp4vdepay ! ffdec_mpeg4 ! ffmpegcolorspace ! videoscale ! autovideosink ------>THIS IN PC

 

MESSAGE COMING FROM SERIAL PORT:

 

root@freescale ~$ gst-launch  mfw_v4lsrc fps-n=30 capture-width=1280 capture-hei

ght=720 capture-mode=4  ! queue ! mfw_vpuencoder codec-type=0 ! rtpmp4vpay ! udp

sink host=192.168.0.105 port=5000

MFW_GST_V4LSRC_PLUGIN 2.0.3 build on Sep 29 2011 15:40:54.

Setting pipeline to PAUSED ...[ALLOC] mem alloc cpu_addr = 0x0  Size 0x150b8

 

[INFO]  Product Info: i.MX53

VPU Version: firmware 13.4.41; libvpu: 5.3.2

ALLOC] mem alloc cpu_addr = 0x0  Size 0x100000

mMFW_GST_VPU_ENCODER_PLUGIN 2.0.3 build on Sep 29 2011 15:40:26.

Pipeline is live and does not need PREROLL ...

mxc_ipu mxc_ipu: IPU Error - IPU_INT_STAT_5 = 0x00000001

Setting pipeline to PLAYING ...

New clock: GstSystemClock

[ALLOC] mem alloc cpu_addr = 0x0  Size 0x20000

[ALLOC] mem alloc cpu_addr = 0x0  Size 0x151800

[ALLOC] mem alloc cpu_addr = 0x0  Size 0x151800

[ALLOC] mem alloc cpu_addr = 0x0  Size 0x151800

 

MESSAGE COMING FROM HOST PC:

ubuntu@ubuntu:~$ gst-launch udpsrc port=5000 caps ="application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)MP4V-ES, profile-level-id=(string)6, config=(string)000001b006000001b59113000001000000012000c888800f528045a14103, payload=(int)96, ssrc=(guint)1681410059, clock-base=(guint)1864923366, seqnum-base=(guint)10851" ! gstrtpjitterbuffer ! rtpmp4vdepay ! ffdec_mpeg4 ! ffmpegcolorspace ! videoscale ! autovideosink

Setting pipeline to PAUSED ...

Pipeline is live and does not need PREROLL ...

Setting pipeline to PLAYING ...

New clock: GstSystemClock

 


NOTE :


I THINK THERE IS NO ERROR SHOWING IN THE SERIAL PORT OR PC

THE PROBLEM I THINK IS CAPTURING VIDEO IS NOT ABLE TO SEND TO THE HOST PC, IT CANT FIND THE PATH TO SENT THE CAPTURING VIDEO


THANKS,

REGARDS,

SHAN,

+91 96117 27927


Outcomes