AnsweredAssumed Answered

Freedom board + CodeWarrior10.3 = no working USB projects?

Question asked by Frost on Oct 31, 2012
Latest reply on Apr 11, 2013 by Steven Cohen

I spent several frustrating hours last night, nearly getting USB projects to work on the freedom platform. To be clear, I've got OpenSDA working, latest drivers, latest codewarrior (special edition) and done some basic GPIO / timer / interrupt work with the board.

 

Bear in mind I'm trying only to get a **CDC Device** project working, nothing more.

 

So, I tried:

1. importing baremetal code (file by file) and re-writing to work around a clean PE project - compiled with errors pointing to a a file on a drive that doesn't exist on my machine, so I couldn't find / resolve these. No luck.

 

2. Processor expert USB project, using USB Stack and docs as a guide. Followed the CDC implementation, except for Freedom board, not K60 as was in the guide. Main system clk was set 96MHz PEE config, 48MHz sys clk and 24MHz IPBUS / peripheral, all working ok. Go through the CDC steps and it then says the OTGEN bit is set, and won't generate PE code. No way to change this, as PE wont let me change code it hasn't generated yet, and I change the register setting in basic / advanced / expert with or without the graphic box enabled.

 

3. My memory is hazy here, forgive me, but I imported a USB stack example CDC project and tried compiling that. I got errors here also.

 

Has anyone managed to get a plain CDC device implementation working on their freedom board? As I said, I've played around with the basics, debugging and basic operation is ok. Do I have to resort to Keil? At least their examples seemed to work. Anyone got any suggestions here?...

Outcomes