AnsweredAssumed Answered

Debug connect problems in CodeWarrior 10.3 on Win XP in VirtualBox on Ubuntu 12.04

Question asked by injunear on Oct 29, 2012
Latest reply on Nov 4, 2012 by injunear

For others trying this: along with installing the drivers in windows as described in a number of other places, one also needs 3 USB drivers installed in the USB Settings of VirtualBox; one for the MSD mode, one for the Bootloader mode, and one for P&E Debug mode.


MSD mode: Vendor ID (VID) 1357, Product ID (PID) 0707

Bootloader mode: VID 2504, PID 0200

Debug mode: VID 1357, PID 0087


At one point I was not able to connect with all the extra text in the other fields in one of the driver configurations so I deleted everything but the VID and PID. (I am hoping that is not the cause of the following problem. ;-)


I spent the last 3 days trying to find all the little settings that allowed me to run CodeWarrior on VirtualBox. I finally got it running except for not being able to connect to the board in Run or Debug Configurations.


I go to Debug Configuration, I select a project (including the downloaded program example, ”FreedomTSITest”) and the “Connection” shows my project name, as expected. I select Edit and make sure the Target shows my project name.


However, under the target name, the Connection type shows P&E ARM Multilink etc. The drop down menu gives me two other selections, neither of which I expect are valid for my situation.


Below that, in the Connection tab, my interface is listed as OpenSDA Embedded Debug - USB port, and that is what I expect to see.


Lastly, in the “Port” field I see “Port undetected” etc., which I expect is not the correct setting.


I tried unplugging, replugging, and refreshing countless times.


I tried loading the 102, 101, and 100 versions of the debug driver onto the bootloader (reset down while powering on) and I am quite stuck at the moment.


I have read everything on this site and both the Element14 and MCU on Eclipse sites that relates to CodeWarrior 10.3 and anything remotely related to this issue. (Probably 4-5 times each at least.)


I am humbly asking for any suggestions or solutions anyone cares to offer.

 

Thank you.

 


Outcomes