AnsweredAssumed Answered

FRDM-KL25Z - cannot connect from CodeWarrior (resolved)

Question asked by Matthew Smith on Oct 21, 2012

Using CodeWarrior 10.3b, trying to play with Erich Styger's examples.

 

I have attempted this on both Windows XP Home and Windows 7 Home Premium.  Both of these are virtual machines, running under VirtualBox - I do not have a physical Windows machine (this is a Linux shop) on which to try this, but can advise that my XP VM plays quite happily with CodeWarrior 10.2 and the PE Micro USB Multilink for HCS08. (I have also used other weird and wonderful USB devices with this configuration, without any issues.)

 

Here is what I have done, with a clean and up-to-date Windows 7 installation:

 

  • Connect Freedom Board - no hubs used, direct connection. This shows up in the VirtualBox USB device manager as "PE Microsystems Inc. PEMicro/Freescale CDC Serial Port [0800]." Just in case I had done anything daft like plug the cable into the wrong socket, I tried the other, which came up as "Freescale USB UART."
  • Enable USB device - Windows detects and an AutoPlay dialogue comes up, showing USB storage. I am able to view the files on the device.
  • Launch CodeWarrior, with project from before.
  • Run -> Debug - the VirtualBox USB manager thingy shows definite activity.
  • P&E Connection Assistant dialogue comes up:
    • OpenSDA - USB Port
    • (No Device Available)
    • Retry doesn't get me any further.
    • Abort
    • "Error launching freedom1_FLASH_OpenSDA, ARM GDI Protocol Adapter: Can't connect. The Debugger can not connect to the P&E device"
  • Run -> Debug Configurations
  • Follow FAQ #29 link (this actually refers to Multilink/Cyclone, NOT OpenSDA.)
  • (a) Re-enable the USB driver
    • Device Manager -> Jungo - only WinDriver present. "This device is working properly."
    • Driver date 2012-08-27, version 11.1.0.0
  • (b) Re-install the USB driver (done, rebooted, no difference)
  • (c) Test for installation of the USB driver files (done, all OK)

 

Which leaves me still unable to connect to the target board. As I had a pair of boards when I was doing this (I now have four due to an error at Element14, but they let me have the extras for free ) I tried the second board just in case there was a hardware issue. No joy.

 

The USB cable I am using works just fine with my Bus Pirate - and me totally out of ideas.

 

So, pending some revelation that will get me working, I'll just have to go and play with my TI Stellaris Launchpad, if I want any fun with ARM

 

Message was edited by: Matthew Smith See end of thread for fix (missing firmware.)

 

Message was edited by: Matthew Smith  I have now appended the dmesg output for a device before and after having the firmware updated/added, for reference.

Original Attachment has been moved to: frdm_dmesg.txt.zip

Outcomes