AnsweredAssumed Answered

3.0.35 kernel on iMX6Q Sabre Lite

Question asked by Marcin Miklas on Oct 8, 2012

I've recently tried the 3.0.35 kernel from L3.0.35_12.09.03_ER. It is very unstable no matter what kernel configuration I'm using, even on kernel provided in debian package in L3.0.35_12.09.03_ER

 

It crashes with errors like:

 

Unable to handle kernel paging request at virtual address ffffffff

pgd = ba2f4000

[ffffffff] *pgd=4fffe821, *pte=00000000, *ppte=00000000

Internal error: Oops: 17 [#1] PREEMPT SMP

Modules linked in:

CPU: 1    Not tainted  (3.0.35 #1)

PC is at anon_vma_clone+0x4c/0x158

LR is at anon_vma_clone+0x3c/0x158

pc : [<800e0504>]    lr : [<800e04f4>]    psr: a00f0013

sp : bff8be78  ip : 0bfd7000  fp : 80ad8d40

r10: 00000000  r9 : ba142cf0  r8 : baa561c8

r7 : bff0e840  r6 : 00000000  r5 : ffffffff  r4 : bfa31f78

r3 : bff8a000  r2 : 80a7fc90  r1 : 8003d004  r0 : bfa31f78

Flags: NzCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user

Control: 10c53c7d  Table: 4a2f404a  DAC: 00000015

Process init (pid: 1, stack limit = 0xbff8a2f0)

Stack: (0xbff8be78 to 0xbff8c000)

be60:                                                       2ab98fff bff0e878

be80: 80ad8d20 ba142cb8 bff0e840 ba142cb8 bff0e754 80acdd20 00000001 bff0e738

bea0: bc0b07dc 800e0630 bff0e840 bfc29040 ba142cb8 bff0e754 80acdd20 8007138c

bec0: bffd2054 00000020 bff0e744 bff0e758 bfc28000 bff8a000 bfc2803c bfc2907c

bee0: bc0178cc ba050000 01200011 80acdd20 bff8bf08 00000000 bff8bfb0 bff8a000

bf00: 7eabd718 80072118 bfd82c80 80a97fe0 ba0501d8 ba0501d0 bff8a000 00000000

bf20: 00000000 ba050124 00000020 00000000 bffd2000 01200011 00000000 2ab91360

bf40: 00000000 800416c4 bff8a000 00000000 2ad08000 80072534 2ab913c8 00000000

bf60: 00000000 bff8bf80 800416c4 7eabd91c 00000008 00000000 7eabd91c 80081910

bf80: 7ffbfeff fffffffe 00000000 00000000 0000000b 2ab913c8 7eabd720 2ab91360

<0>bfa0: 00000078 80041540 00000000 2ab913c8 01200011 00000000 00000000 00000000

bfc0: 2ab913c8 7eabd720 2ab91360 00000078 2ab91820 00000001 00000001 2ad08000

bfe0: 00000078 7eabd718 2ac97edf 2ac41276 000f0030 01200011 00000000 00000000

[<800e0504>] (anon_vma_clone+0x4c/0x158) from [<800e0630>] (anon_vma_fork+0x20/)

[<800e0630>] (anon_vma_fork+0x20/0x130) from [<8007138c>] (dup_mm+0x1a8/0x4d8)

[<8007138c>] (dup_mm+0x1a8/0x4d8) from [<80072118>] (copy_process+0x9e4/0xdb8)

[<80072118>] (copy_process+0x9e4/0xdb8) from [<80072534>] (do_fork+0x48/0x2a4)

[<80072534>] (do_fork+0x48/0x2a4) from [<80041540>] (ret_fast_syscall+0x0/0x30)

Code: e2504000 11a0a006 0a000024 e5985004 (e5956000)

---[ end trace 8479eb65fc3380dc ]---

 

Virtual addresses are different each time.

 

With kernel 3.0.15 and the same rootfs everything works perfectly. Have somebody experienced simillar issue?

 

Googling the issue suggests that the broken memory might be an issue, but I run the memcheck program on 3.0.15 kernel and it founds nothing.

 

I would really appreciate any help.

 

Regards,

Marcin Miklas

 

PS. More crashes attached.

Original Attachment has been moved to: 3.0.35_crashes.zip

Outcomes