AnsweredAssumed Answered

5V supply on MC9S08SH16 & SH32 TSSOP28 kills chip?

Question asked by John Dowdell on Sep 14, 2012
Latest reply on Oct 15, 2012 by Pedro Augusto Panecatl Salas

I usually assume I've done something wrong and I might still have but I'm running out of ideas and tests that would prove it....

 

I had a board that I had loaded a MC9S08SH32 onto. On first application of supply which was 5V via a regulator, It appeared to have a short. After searching for a while, it appeared to be the chip so I changed it. That chip and another I changed after it didn't seem to appear to have quite the same short and I could load some firmware onto it to toggle at LED but the pin wouldn't pull to ground. Any load, even a very light load on the pin mean that it wouldn't pull to ground. After a while of playing around with it and running out of SH32 chips I left it.

 

Some days later I populated a similar board based on the first design. Same problem. Had some more SH32 TSSOP28 chips by then and tried another couple of chips.

 

So now I was at the point where I decided i needed to test the remaining couple of IC's I had on hand in isolation from that design. I have some tssop breakouts so I set one up with crystal and reset circuitry and connected it to 5V on my bench power supply. It died immediately. Had my bench power supply current limited at about 500mA and its pulling that current. something internal to the IC is "shorting" Checked my circuit. It looked ok.

 

I wanted to use the chip at 5V but I knew it operated down to ~3V so I changed out that IC with another SH32 and set it up for 3.3V. OK so at 3.3V it has no problem. I didn't measure the current but the needle on the bench p/s hardly deflected. I then disconnected it, changed the p/s to 5V at reconnected. The chip died. Checked my circuit again, checked the pinouts etc. all appears correct. Did the same test again with another chip and it dies again.

 

Up to this point, I was getting the chips from element14. At this point nothing different has happened with my tests so I decided to try a different chip in the same family and footprint and from a different supplier so I got 14 SH16 TSSOP28 IC's direct from Freescale.

 

With the same TSSOP board I had been using to test before I tried the same test again with an SH16. 3.3V:OK. 5V: chip dies.

 

Well I've killed enough chips on that setup by this point. Now I figure I should go back to some mimium test so I grab a new tssop breakout and just connect VDD and VSS. 3.3V: OK, 5V:Chip dies.

 

Nothing in the datasheet or errata popped out at me and screamed "this chip in the family cant handle 5V!".

However all the symptoms that I've experienced thus far with both ICs is suggesting to me that that is the case.

 

Has anybody experienced this in the SH family? especially the tssop package?

Is there anyone out there who is willing to do the same test and prove me correct or crazy?

 

JD

Outcomes