AnsweredAssumed Answered

Macromedia Director Xtra's Issue.

Question asked by Vijayalakshmi Shetty on Jun 18, 2007
Latest reply on Jun 18, 2007 by Tom Thompson
Hello Group,


Since I am new bee to the lingo scripts, I am looking forward help form experts of Director Xtras developer.

We have a startup Director movie, which is developed in Director Version 7. Now I am trying to open the same Director movie on Director MX 2004 Version 10.1 Trial version( On Mac OS X Version 10.4.6 ).

I am facing some strange problem in the Lingo script. The startup Director movie ( developed in Director Version 7 ) depends on some Xtras, we have the source code for those Xtras. I could be able to build those Xtras under CodeWarrior IDE 4.1. The result of the build product is Macromedia Director/Shockwave Xtra ( obtained after changing the Creator and Type settings under the code warrior project setting ). I installed the built Xtra in Xtras folder
of the Director application ( Mac OS X 10.4 platform ). I tried to use the installed Xtra by using initialising the Xtra like,

Obj = xtra( " TestXtra " ) . new()
put xtra( " TestXtra " ) . interface()


but the Director is giving script error like TestXtra not found. What would be the workaround for this problem...?

Is there any documentation on how to use such Xtras...

Is there anything additional settings that we need to do with the Director or with the Codewarrior to build Xtra...!


But I downloaded a Xtra named QTAudioXtra from the Internet. The project file of the QTAudioXtra is in CodeWarrior IDE 5.1. I compiled the source under CodeWarrior IDE 5.1 and used the built Xtra as like third party Xtras. This worked fine. In this project while compiling I used Carbon library. But in the project which I mentioned in the beginning I did not used any Carbon library.

Is this cause problem...

Any inputs for this issue...

Looking forward for your reply...

Thanks in advance,
Viji

Message Edited by viji on 2007-06-18 02:21 PM

Message Edited by viji on 2007-06-18 02:22 PM

Outcomes