AnsweredAssumed Answered

LTIB "Failed building wget" undefined reference to `SSLv2_client_method'

Question asked by AdCmo on May 21, 2012
Latest reply on Nov 8, 2016 by Narreddi Siva Prakash Reddy

I was following the LTIB guide:

Ubuntu 11.10 Oneiric 64-bit Virtual Machine and building i.MX53 L2.6.35-11-09-01

 

I got past the zlib issues by following:

http://vijay496.blogspot.com/2012/03/ltib-for-ubuntu-1110-error-fac...


Now: I am having wget package failing.
I am running Ubuntu 11.10, 32-bit.

 

Anyone ever got the error below, thanks?
 

Ad.
-----------------

gcc -O2 -Wall -Wno-implicit -o wget cmpt.o connect.o convert.o cookies.o ftp.o ftp-basic.o ftp-ls.o ftp-opie.o hash.o headers.o host.o html-parse.o html-url.o http.o init.o log.o main.o gen-md5.o netrc.o progress.o rbuf.o recur.o res.o retr.o safe-ctype.o snprintf.o gen_sslfunc.o url.o utils.o version.o -lssl -lcrypto -ldl
gen_sslfunc.o: In function `init_ssl':
gen_sslfunc.c:(.text+0x351): undefined reference to `SSLv2_client_method'
collect2: ld returned 1 exit status
make[1]: *** [wget] Error 1
make[1]: Leaving directory `/opt/freescale/ltib/usr/src/rpm/BUILD/wget-1.9.1/src'
make: *** [src] Error 2
error: Bad exit status from /home/me/imx53/11.09.01/ltib/tmp/rpm-tmp.33663 (%build)


RPM build errors:
Bad exit status from /home/me/imx53/11.09.01/ltib/tmp/rpm-tmp.33663 (%build)
Build time for wget: 21 seconds

Failed building wget
Died at ./ltib line 1380.
traceback:
main::build_host_rpms:1380
main::host_checks:1435
main:542


Started: Mon May 21 00:16:07 2012
Ended: Mon May 21 00:16:28 2012
Elapsed: 21 seconds

These packages failed to build:
wget 

Build Failed

Outcomes