Ryan Begg

i.MX53 EIM

Discussion created by Ryan Begg on Apr 30, 2012
Latest reply on Oct 8, 2012 by Brad Stewart

Hi,

I am trying to write to the configuration registers for the EIM on the i.MX53. I am running Linux (kernal 3.0.0) and I have tried writing to the registers from both a user space program, using mmap(), and a kernel module using the MX53_IO_ADDRESS macro. In either case the device registers don't accept the changes I am writing. I have successfully written to the GPIO and IOMUX registers using the same methods. Specifically I want to set the data port size, enable multiplex mode, and enable the chip select in the CSxGCR1 register. I have tried CS0 and CS1 ensuring the IOMUX_GPR1 register is configured appropriately for the different CS options.

 

Ultimately I would like to use EIM_DA[0..15] to interface to an FPGA in order to read sample data from an internal dual port ram on the FPGA. I believe any of the 4 chip selects will work. Currently with the CS0 default configuration when I try to read an address the processor hangs and requires a reboot. I used mmap() at address 0xF0000000.

 

Any help would be greatly appreciated.

Outcomes