Kushal Kushal

LTIB build fails for i.mx6

Discussion created by Kushal Kushal on Apr 25, 2012
Latest reply on May 27, 2013 by zhanxiaozhang

Hello Community,


I am trying to create cross development environment for building software for I.MX 6 board. I downloaded software packages from compass and here are the the package names.
L2.6.38_MX6DQ_ ER_1201
L2.6.38_12.01.01_ER_source.tar.gz

 

Now I am following i.MX 6Dual/Quad SABRE-Lite Linux User's Guide" document to build LTIB.  I did install LTIB my way as document does not match with source/package structure. L2.6.38_12.01.01_ER_source has install scripts which does it I guess.

After installing LTIB, I am failing to configure or build it. Please look at log below. I can see one typo but do not know how to fix it. Does anyone has patch for it? or any workaround?


If anyone has out of box instructions with package to create Linux build environment for i.mx6?


----------
LOG
----------
$ ./ltib -m config

Installing host support packages.

This only needs to be done once per host, but may take up to
an hour to complete ...

If an error occurs, a log file with the full output may be found in:
/home/kushal/ltib/host_config.log

Exiting on error or interrupt
Please see >> /home/kushal/ltib/host_config.log for details
kushal@kushal-ubuntu-09-04:~/ltib$
kushal@kushal-ubuntu-09-04:~/ltib$ cat host_config.log

Processing platform: host support
===================================

Processing: rpm-fs
====================
ERROR: /tmp/rpm-kushal/RPMS/i686/rpm-fs-4.0.4-1.i686.rpm
would clobber '/reescale/ltib'
traceback:
main::check_host_clobber:2674
main::build_rpm:906
main::f_buildrpms:980
main::check_rpm_setup:2405
main::host_checks:1423
main:542
-----------

Thank you,
Kushal

Outcomes