Antonio Gabriele

IMX53 Xorg Segmentation fault

Discussion created by Antonio Gabriele on Apr 6, 2012

Dear, I build a rootfs with ltib, including Xorg server.

It build without error, but when I run Xorg I get:

root@embed /dev$ Xorg
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/embed:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.6.1
Release Date: 2009-4-14
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-21-generic i686
Current Operating System: Linux embed 2.6.35.3-1129-g691c08a #1 PREEMPT Wed Mar 21 12:30:30 PDT 2012 armv7l
Build Date: 27 March 2012  02:54:07AM

        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/usr/var/log/Xorg.0.log", Time: Thu Jan  1 03:10:44 1970
(==) Using config file: "/etc/X11/xorg.conf"
Segmentation fault

I cannot understand where the problem is.

This is GDB output:

Remote debugging using 192.168.21.251:8888
0x2aaab7a0 in ?? ()
(gdb) continue
Continuing.
Cannot access memory at address 0x0

Program received signal SIGILL, Illegal instruction.
0x00011c04 in ?? ()
(gdb) continue
Continuing.
Cannot access memory at address 0x4446

Program received signal SIGSEGV, Segmentation fault.
0x00011c04 in ?? ()
(gdb) continue
Continuing.
Cannot access memory at address 0x4446

Program received signal SIGSEGV, Segmentation fault.
0x00011c04 in ?? ()
(gdb) continue
Continuing.
Cannot access memory at address 0x4446

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb) exit
Undefined command: "exit".  Try "help".
(gdb) quit

I attach my LTIB configuration.

Attachments

Outcomes