Maciej Suminski

Xorg GLX & DRI support for i.mx51 GPU

Discussion created by Maciej Suminski on Apr 2, 2012

Hello,

I've seen that some of the i.mx51 systems include glx & dri extensions - how did you obtain them?

I've tried to enable GPU acceleration, but there is something wrong - if I run es11ex demo (using Xfbdev), it runs only at ~12 FPS instead of ~120 FPS. On Xorg it doesn't run at all:

root@orson ~$ es11ex
Press Enter to terminate...
Not all allocated memory blocks were freed. Doing it now.
Freeing list entry #0, gpuaddr=aa300000
Freeing list entry #1, gpuaddr=aa305000
Freeing list entry #2, gpuaddr=aa30a000
Freeing list entry #3, gpuaddr=aa30f000
Freeing list entry #4, gpuaddr=aa314000
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 20 rNot all allocated memory blocks were freed. Doing it now.
equests (19 known processed) witFreeing list entry #0, gpuaddr=aa319000
h 0 events remaining.
Freeing list entry #1, gpuaddr=aa31a000
Freeing list entry #2, gpuaddr=aa32a000
Freeing list entry #3, gpuaddr=aa35c000
Freeing list entry #4, gpuaddr=aa35d000
[1] + Segmentation fault         Xorg :0

These are messages that I get while I try to run Xorg:

root@orson ~$ Xorg :0
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/orson:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.6.1
Release Date: 2009-4-14
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.38-13-generic-pae i686
Current Operating System: Linux orson 2.6.35.3-433-g0fae922icom-g6c583a7-dirty #42 PREEMPT Mon Apr 2 08:47:36 CEST 2012 arml
Build Date: 02 April 2012  08:48:11AM
 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/usr/var/log/Xorg.0.log", Time: Thu Jan  1 02:13:30 1970
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "glx" (module does not exist, 0)
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/evdev
(EE) XKB: No components provided for device Virtual core keyboard
mxc_ipu mxc_ipu: Channel already disabled 9
mxc_ipu mxc_ipu: Channel already uninitialized 9

 

And this is my xorg.conf (created by default with Xorg):

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
EndSection

Section "Device"
    Identifier    "i.MX Accelerated Framebuffer Device"
    Driver        "imx"
    Option        "fbdev"        "/dev/fb0"

# This option only recognized when "mxc_epdc_fb" frame buffer driver in
# use.  Values are "RGB565" (default, 16-bit RGB), "Y8" (8-bit gray),
# and "Y8INV" (8-bit gray inverted).
    Option        "FormatEPDC"    "Y8INV"

EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "i.MX Accelerated Framebuffer Device"
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
EndSection

Outcomes