PierantonioTabaro

reset fail with VDD5V < 5.0V

Discussion created by PierantonioTabaro on Mar 28, 2012
Latest reply on Aug 27, 2014 by fear_nada

Hi,

i have a board powered only with VDD5V, no battery, the power supply is based on a LM2675-5.0 and  output voltage is 4,97V.

The board boot-up and run correctly, but i am not able to reset with the reset button connected to RESETN pin.

Also the reset command from linux console don't work.

I have this boot sequence: u-boot then kernel, i think that the problem is on the kernel:

If press reset anytime when u-boot is booting the reset work.

If i press the reset before the kernel is starting init "init started: BusyBox v1.15.0 ()", the reset work.

If i press reset when the board is up at login, the reset cannot work anymore, nothing is printed out on debug console and the only way is power off and on the board.

With power off and on sequence the board is running well without any issue, i have uptime of days.

If i power the board with an external power supply the reset button work anytime, the only difference is that the external power supply is giving 5,28V.

There is a kernel setting on power or regulators that need to be changed?

 

when reset command from console work:

==cut==

The system is going down NOW!
Sent SIGTERM to all processes
Sent SIGKILL to all processes
Requesting system reboot
Restarting system.


PowerPrep _start

PowerPrep start initialize power...

Configured for 5v only power source.
Battery powered operation disabled.

==cut==

 

when reset command from console don't work:

==cut==

The system is going down NOW!
Sent SIGTERM to all processes
Sent SIGKILL to all processes
Restarting system.

Unde

==cut==

I see the partial word "Unde", but on kernel there is a lot of this words :-(

Also the "Requesting system reboot" line is missed when the reset don't work.

 

The reset/pswitch schematic is the same as the EVK.

 

Please help me.

Outcomes