Jack Sun

[i.MX28 EVK] Can't ping to local network

Discussion created by Jack Sun on Mar 8, 2012
Latest reply on Mar 13, 2012 by Jack Sun

Hi All,  I have a i.MX28 EVK Rev. D board.

I met a network problem.

I started Linux in the SD Card provided by freescale, although failed in starting graphics. Then set the ipaddress(192.168.1.66). But I failed in ping to another local machine.

I raised a service request to freescale. They said that there was problem with ethernet in [ EVK Rev. D].

So I tried ②

②I rebuilt LTIB, set the ipaddress and burned the image to a new SD card. Then I tried it on the board. Start was OK, but PHY attachment failed. 

**********************

freescale login: PHY: 0:00 - Link is Up - 100/Full
PHY: 0:00 - Link is Down
FEC: MDIO read timeout
FEC: MDIO read timeout

......

root@freescale ~$ ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:04:9F:01:D3:98
inet addr:192.168.1.66 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Base address:0x8000

*************************************

Then i tried the follow 

**************************

root@freescale ~$ ifconfig eth0 down
root@freescale ~$ FEC: MDIO read timeout

root@freescale ~$ ifconfig eth0 up
FEC: MDIO read timeout
eth0: Could not attach to PHY
ifconfig: SIOCSIFFLAGS: Connection timed out
root@freescale ~$

***********************

Is this has something to do with ethernet driver?

Should I modify fec.c and rebuilt the Linux?

Help me.

Thanks.

Outcomes