Frederic COIFFIER

Green videos when using Gstreamer's videorate and mfw_vpuencoder

Discussion created by Frederic COIFFIER on Jan 23, 2012
Latest reply on Apr 30, 2013 by Janis Coders

Hello,

 

On the i.MX53 QSB, I'm using a GStreamer pipeline to generate an RTP stream and until now, it worked fine with H.264 output. But, as I needed to reduce the framerate of my video, I tried the usual 'videorate' plugin provided by GStreamer.

 

But when I insert the videorate plugin in my pipeline (even if I don't modify the framerate !!), I get a green video (see attachment) :

gst-launch -v mfw_v4lsrc capture-width=720 capture-height=576 ! videorate ! mfw_vpuencoder codec-type=std_avc ! avimux ! filesink location=/tmp/test.avi

(VLC doesn't recognize the video but I can read it with mplayer, DragonPlayer and GStreamer)

 

If I remove the videorate, it works fine :

gst-launch -v mfw_v4lsrc capture-width=720 capture-height=576 ! mfw_vpuencoder codec-type=std_avc ! avimux ! filesink location=/tmp/test.avi

 

I use the L2.6.35_11.09.01_ER_source with IMX_MMCODECS_11.09 and the latest update L2.6.35_MX53_201112_Patches.

 

Is there someone who uses the same videorate plugin ? Is it a known problem and is there a workaround ?


Attachments

Outcomes