KrishnaPavan

amd-gpu-bin-mx51-10.11.01-1 fails to build

Discussion created by KrishnaPavan on Dec 14, 2011
Latest reply on Jan 12, 2012 by KrishnaPavan

amd-gpu-bin-mx51-10.11.01-1

Ubuntu 10.04, ltib 9.1.1, i.MX51_EVK

Trying to build Qt!

 

Following Instructions from http://www.imxdev.org/wiki/index.php?title=All_Boards_Qt

 

Error Log:

Processing: amd-gpu-bin-mx51
==============================
sudo /opt/freescale/ltib/usr/bin/rpm --root /home/krishna/ltib/rootfs --dbpath /var/lib/rpm -e --allmatches --nodeps --define '_tmppath /tmp/ltib' amd-gpu-bin-mx51 2>/dev/null
sudo /opt/freescale/ltib/usr/bin/rpm --root /home/krishna/ltib/rootfs --dbpath /var/lib/rpm --prefix / --ignorearch -ivh --force --excludedocs --define '_tmppath /tmp/ltib' /home/krishna/ltib/rpm/RPMS/arm/amd-gpu-bin-mx51-10.11.01-1.arm.rpm
error: failed dependencies:
    libc.so.6(GLIBC_2.11)   is needed by amd-gpu-bin-mx51-10.11.01-1

f_buildrpms() returned an error, exiting
traceback:
 main:560

Started: Wed Dec 14 17:33:46 2011
Ended:   Wed Dec 14 17:35:52 2011
Elapsed: 126 seconds

Build Failed
Exiting on error or interrupt

*****************************CHECK FOR (soname) RESULTED IN************************************

 ldd -v /bin/sh
    linux-vdso.so.1 =>  (0x00007fffeb9f1000)
    libc.so.6 => /lib/libc.so.6 (0x00007f47a95d2000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f47a9969000)

    Version information:
    /bin/sh:
        libc.so.6 (GLIBC_2.4) => /lib/libc.so.6
        libc.so.6 (GLIBC_2.3) => /lib/libc.so.6
        libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
        libc.so.6 (GLIBC_2.11) => /lib/libc.so.6
        libc.so.6 (GLIBC_2.2.5) => /lib/libc.so.6
    /lib/libc.so.6:
        ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
        ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2

 

Please kindly suggest!

Outcomes