Lu Yinyin

Phonon for imx53 doesn't work properly

Discussion created by Lu Yinyin on Dec 4, 2011

Hi guys,

I am trying to implement Phonon for imx53. gst-launch works fine on my platform, but no sound from phonon. My default setting in asound.conf is
pcm.!default {
type hw
card 0
device 0
subdevice 3
}
or
pcm.!default {
type plug
slave {
pcm "hw:0,0,3"
}
}
both ok. I checked /proc/asound and i found two cards :card0 is imxesai and card1 is imx3stack. i tried like "gst-launch playbin2 uri=file:///dir/k.wav" and it works fine.
I used Phonon::BackendCapabilities::availableAudioOutputD evices() and found out i have four devices available:
default
hw:0,0
hw:1.0
hw:1.1
i can't see subdevices in phonon but i set defaults.pcm.subdevice to 3 in asla.conf.

i also tried audioOutput->setOutputDevice(audioOutputDevices.at(1)) and other devices but still no luck.

Now i don't know what to do next...
Plus, i start imx53 using nfs on ubuntu, does that matter?
I also wanna know how phonon get available device list? it seems that it doesn't get asound default setting.
some more information abount my platform:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: imxesai [imxesai], device 0: imxesai PCM [imxesai PCM]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 1: imx3stack [imx-3stack], device 0: Voice SSI-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: imx3stack [imx-3stack], device 1: Bluetooth SSI-1 []
Subdevices: 1/1
Subdevice #0: subdevice #0

No error message during playing, but no sound...
here is message from phonon:
ASFPARSER_00.02.09 build on Jun 22 2010 09:10:09.
MFW_GST_ASF_PLUGIN 1.9.0 build on Feb 3 2011 12:16:46.
WMA10D_03.03.00_CORTEX-A8 build on Jul 22 2010 18:06:11.
MFW_GST_WMA10DEC_PLUGIN 1.9.0 build on Feb 3 2011 12:16:30.

Thanks!

Outcomes