Maxim Anisimov

Viewing a multicast video stream on the imx53 Quick Start Board

Discussion created by Maxim Anisimov on Nov 23, 2011
Latest reply on Dec 7, 2011 by Maxim Anisimov

Hi, I want to play multicast video stream on the imx53 Quick Start Board (Ubuntu 10.04 L2.6.35_11.09.01). But the device can not play it correctly for reasons unknown to me. My network scheme is following:494-NetworkScheme.png

To play a multicast video on the device, I did the following:

1) Network buffer of the device was increased and IGMP setted to v2

echo 204800 > /proc/sys/net/core/rmem_max

echo 2 > /proc/sys/net/ipv4/conf/all/force_igmp_version

echo 2 > /proc/sys/net/ipv4/conf/default/force_igmp_version

2) imx53 Quick Start Board getting network settings from DHCP service.

3) for playing udp stream to network I used notebook with VLC player running. To run VLC I made the following:

a) Tools->Preferences(Show settings - switch to all)->Stream Output->Access Output. Set "Multicast output interface" and "IPv4 multicast output interface address" to my ip address of notebook network interface.

b) We can play video using next steps. Open "Media" menu, next "Streaming", add video file to list, press button "Stream", press button "Next" on the new opened dialog, select "New destination" to UDP (legacy), press button "Add", set address to 239.0.0.1 and port to 1234, uncheck "Activate transcoding", then press "Stream" button to start streaming video.

4) On the device I try to use the following commands:

gst-launch udpsrc multicast-group=239.0.0.1 auto-multicast=true port=1234 buffer-size=1000000 ! decodebin2 use-buffering=true max-size-buffers=32 max-size-bytes=1000000 ! mfw_v4lsink

gst-launch udpsrc multicast-group=239.0.0.1 auto-multicast=true port=1234 ! decodebin2 ! mfw_v4lsink

 

The log of commands:

MFW_GST_V4LSINK_PLUGIN 2.0.3 build on Nov 12 2011 10:13:27.
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Aiur: 2.0.3
Core: BLN_MAD-MMLAYER_MPG2PARSER_ARM11_04.00.05 build on Sep 22 2011 11:18:22
mime: video/mpeg, mpegversion=(int)[1,2]; video/mpegts,
systemstream=true; video/x-cdxa
file: lib_mpg2_parser_arm11_elinux.3.0.so.4.00.04
Content Info:
Seekable : No
Size(byte): -1

Mpeg2CreateParser:parser created successfully
Movie Info:
Seekable : No
Live : Yes
Duration : 0:00:00.000000000
ReadMode : File
AutoRetimestamp: 2000ms
Track : 2

Track 00[Audio]: Enabled
Duration: 0:00:00.000000000
Language:
Mime:
audio/mpeg, mpegversion=(int)1, parsed=(boolean)true,
channels=(int)2, rate=(int
)48000, bitrate=(int)384
BLN_MAD-MMCODECS_MP3D_ARM_02.10.00_CORTEX-A8 build on Jul 7 2011 11:02:16.
MFW_GST_MP3_DECODER_PLUGIN 2.0.3 build on Nov 12 2011 10:13:37.
Track 01[Video]: Enabled
Duration: 0:00:00.000000000
Language:
Mime:
video/x-h264, parsed=(boolean)true, width=(int)1920,
height=(int)1088, framerate
=(fraction)30/1
[INFO] Product Info: i.MX53
VPU Version: firmware 13.4.41; libvpu: 5.3.2
MFW_GST_VPU_DECODER_PLUGIN 2.0.3 build on Nov 12 2011 10:13:04.

 

On log it is clear that the video was detected, but we could not see anything on the screen. Also tried to reproduce the flow through the totem video player (see the screenshots in the enclosure), but also no success.

 

Could Somebody help with this problem?

Someone tried to play the video using multicast UDP streaming?

Outcomes