AnsweredAssumed Answered

CW install; Internal Error 2908

Question asked by Jeff Smith on Mar 20, 2007
Latest reply on Mar 22, 2007 by Jeff Smith
Hi, isn't it my luck that the WaveForum 2007 is in progress but my CW 5.1 (HC08) did not seem to work for the course! It installed once, almost worked, then now I cannot install it at all!
 
I hope I can fix this Tuesday, since that's really the day that I need it.
 
1. First, I installed CW 4.5 (HCS12). Then they told us we only needed the other, CW 5.1, so I left it installed and installed also 5.1. I was following the demonstration, but come time to build the project, it said there was a code size limitation. That meant that the license.dat they had me copy in did not work.
 
2. They mentioned that they've had this sort of problem when they already had another version of CW installed (and I had 4.5), so I uninstalled everything. First 4.5, then 5.1. I even went to "Program Files" and deleted CodeWarrior stuff left over from the two installations. I had never had any other CW installed previously.
 
3. Perhaps I went to far (though I see no reason why this would hurt), but I opened 'regedit' and removed any CodeWarrior stuff from user and local_machine.
 
4. I tried to reinstall CW 5.1, after a few things, it said "Internal Error 2908", and then a huge complicated id in brackets {4ED....-...-.-.-.-...-.-..-.-..-.-....-...BE52C} which is of course meaningless to me (it has a new number for perhaps every file that it tries to install).
 
5. I tried countless ways to recover from this, but simply cannot install CW 5.1 anymore. I can still install CW 4.5, but I don't need that, and doing that again did not restore the ability to install 5.1.
 
Any help?  TIA
 

Outcomes