AnsweredAssumed Answered

Error when using a Simulator target- memory regions not found

Question asked by Raghav Sarma on Mar 15, 2007
Latest reply on Mar 15, 2007 by CrasyCat
Hi everyone,
 
I using Code Warrior 3.1 for HC12 and have built my code for the simulator target. However, when I try running my code in the simulator, I get the following error message:
 
STARTED
RUNNING
No memory at [1200:1] (cal_check)

 
I've run the same code with the a BDM and the actual hardware as target and it worked fine. In fact I got a very similar message when I tried to build another completely independent application also with the simulator.
 
The first application used the RELOCATE command in the prm file to relocate some of the memory during runtime to RAM ( with the RAM section starting at 0x1200). The second application also had certain memory checking features i.e. The data bus test writes a series of bitmaps to RAM, each bitmap having one bit set corresponding to one of the data bus lines (a walking 1's test). The bitmap is read back and if it does not correspond to the just written value, a watchdog reset is invoked.
 
Any idea what can cause these problems when using the simulator?
 
Raghav
 

Outcomes