Patrick Chau

mx53 1920x1080 HD video playback

Discussion created by Patrick Chau on Oct 13, 2011
Latest reply on Oct 18, 2011 by Patrick Chau

Dear All:

        We are testing the 1920x1080 HD video playback on i.MX533QSB board, the setups are:

 

             Linux: 2.6.35.3

             BSP: L2.6.35_11.05.01

             CODEC: 11.05

             GStreamer: 0.10.35


         It is ok to play the 1280x720 video with the following command:

 

           # gst-launch filesrc location=media/H264_DAKEAI.avi ! 'video/x-msvideo' ! aiurdemux name=demux demux. ! queue max-size-buffers=0 max-size-time=0 ! mfw_vpudecoder ! mfw_v4lsink demux. ! queue max-size-buffers=0 max-size- time=0 ! mfw_mp3decoder ! audioconvert ! alsasink

 

         We convert the video by using ffempg:


            # ffmpeg -i H264_DAKEAI.avi -vcodec libx264 -vb 8000K H264_DAKEAI-1.avi


         the video playback still fine. We then convert the video to 1920x1080 with the following command:

 

            # ffmpeg -i H264_DAKEAI.avi -vcodec libx264 -vb 8000K -s 1920x1080 H264_DAKEAI-1080.avi

 

        and using the below command to play the video:

 

             # gst-launch filesrc location=media/H264_DAKEAI-1080.avi ! 'video/x-msvideo' ! aiurdemux name=demux demux. ! queue max-size-buffers=0 max-size-time=0 ! mfw_vpudecoder ! mfw_v4lsink demux. ! queue max-size-buffers=0 max-size- time=0 ! mfw_mp3decoder ! audioconvert ! alsasink

 

          The gst-launch exits with error, the output is in the attached file gst-launch.log. we have tried different format of video file, the errors are the same, so we want to does anybody try the 1920x1080 HD video on i.MX535 board? we have checked the manual for codec, which not much help from that.

 

         Thanks in advance.

 

B. Regards

 

Patrick Chau

Outcomes