Roger Escanhola

Running a program in uClinux

Discussion created by Roger Escanhola on Mar 6, 2007
Latest reply on Mar 12, 2007 by Roger Escanhola
Hi,
I have just bought a kit from Freescale (M5208EVB-E) that I am going to use in my next project. My doubt is how to create a program in Codewarrior (I’m using CodeWarrior Development Studio for ColdFire, version 6.2) and then run it on uClinux.
First I tried to do a simple 'hello world' program in CodeWarrior end then I executed it doing ‘make’ e then ‘run’, it used the USB Coldfire multlink to write the program (in machine code) on the memory (flash or ram, I do not know which one), it worked ok. What I tried after it and it DID NOT WORK, was to get the files generated on CodeWarrior (hello.elf and hello.b, this last one I set to create in the ‘project settings > coldfire linker > generate binary image’) copy them to a folder in the uClinux end then to run this simple program from the uclinux prompt just typing the name program. An error occurred, and I just saw a lot of machine code (scrap) running in the screen. Is there some configuration in Codewarrior that I can change to create the right file to run my application direct on uClinux? If, yes. How do I do that? I got to do this (to run a program on uclinux) using the other IDE that came with the Freescale kit, the SBCTools, it does exactly what I told you above, it compiles the program, write to a folder /mnt/workspace end then I only need to type the programs name and it runs. But I want to learn to do this in the CodeWarrior.
Does anyone have any idea?

Thanks

Outcomes