Gregorio Lopez

Problems with ColdFire_Lite.mcp for M52235EVB

Discussion created by Gregorio Lopez on Mar 5, 2007
Latest reply on Mar 19, 2007 by Gregorio Lopez
Hi,

I am trying to run ColdFire_Lite.mcp (I think it is a web server example) in my board but it is driving me crazy!! I am working with CW v6.3 for CF Special Edition, CF_Flasher and USB_ML_CF. In the last two days I think I have seen all the errors you can imagine.

First of all, I got the error "Exception vector name: Address Error" when I tried to debug the program. Thanks to a thread of this forum I realized that I had to use CF_Flasher to upload the *.s19 file that CW generates when you make the project (that I think is example_flash.S19).

While I was doing that I got the error "Could not initialize BDM device" and thanks to a thread of this forum again I fixed it by copying unit_cfz.dll in the folder windows/system32.

And after doing that, I got the error "PEMicroProtocolPlugin: No USB connection found". I had a look in the forum again and I read that I had to uninstall the drivers of the USB_ML_CF and install them again. I did it and then the USB_ML_CF worked pretty well but CW still gives me this error when I am working with this project (the "Hello World" project seem to work well although today CW has given me the same error when I have tried to debug this program!!).

Is there any documentation (a tutorial or something like that) about how to build and debug this project step by step?

Has somebody any idea about what I have to do to be able to test this project? And how can I do it?

Help me as soon as possible please, because we are loosing too much time!!

Thanks in advance!

Best regards,

Grego

Outcomes