AnsweredAssumed Answered

OpenGL demo programs

Question asked by Phil Endecott on Jun 19, 2011
Latest reply on Sep 22, 2012 by Clay Montgomery
Dear All,  I am trying to run the demo programs in the framebuffer OpenGL package, with mixed success. Has anyone else tried this?  I've installed the amd-gpu-bin-mx51-11.01.00 package, i.e. not the x11 version; this installs various libraries, header files, and test/demo executables:  simple_draw - segfaults tiger - segfaults tiger_ri - At 32 bpp, draws two tigers one above the other, the bottom one flickering. At 16 bpp, draws one tiger. torusknot - segfaults vg11sanity - does nothing c2d_sanity_app_z430 - "tests passed" es11ex - shows a rotating black cube on a grey background gsl_sanity_app - outputs quite a lot of benchmarking info, and then needs ctrl-C, which takes a while to be noticed. resclient_multiprocess_test - says "no such file or directory" a few times, and then finishes. resclient_multitask_test - segfaults resclient_test - segfaults 2dblt_perf - outputs some sane-looking benchmark numbers, but nothing is seen on the screen. c2d_sanity_app_z160 - passes, after lots of "the rotation angle must be..." messages.  For many of these programs, I get repeated console output saying something like "Freeing list entry #12017, gpuaddr=891ce000".  strace shows them doing mostly reasonable things, though I found this surprising:  open("./yamato_panel.txt", O_RDONLY) = -1 ENOENT (No such file or directory) open("c:/yamato_panel.txt", O_RDONLY) = -1 ENOENT (No such file or directory)  Has anyone else tried any of this? Is anyone else using OpenGL, in particular on the framebuffer?

Outcomes