Matt Matt

NFS usually does not work, how to troubleshoot?

Discussion created by Matt Matt on Jun 7, 2011
Latest reply on Apr 22, 2013 by Tim Li

Hi,

 

I am having trouble using NFS on my i.MX28 board.  I am using custom hardware, so I do not know if the issue is with my board or with software.

 

My setup: I have static IP addresses assigned to the host and target so that I don't have to mess with DHCP.  I plug the host and device directly into eachother, no hub/switch/router.  I am running Ubuntu 10.10 on the host, and the ethernet port on the host is set to auto-detect settings.

 

First I set up u-boot to do a network boot.  The FTP always works great, but usually the NFS fails.  I have a pretty poor success rate.  But I do notice, if I cycle the power to the board quickly, I am more likely to fail then if I wait a minute before turning power back on.

 

Another interesting thing, when I was trying to use the u-boot NFS feature, the target would broadcast a "whois" to see where the host was, and the host would reply right away with its MAC address, and then the whole process repeated for a total of 6 times before giving up.  It didn't even start the NFS stuff.  So it seems like the Rx on the target was not working for some reason, or else why would it ask 6 times where the host was? (I think it was 6, but don't quote me on that).

 

I next did a SD card boot, and once everything loaded, I logged in and tried

mount -t nfs 192.168.0.10:/tftpboot/rootfs /mnt/nfs"

...but I get this...

svc: failed to register lockdv1 RPC service (errno 111).

mount: mounting 192.168.0.10:/tftpboot/rootfs on /mnt/nfs failed: Connection refused

 

This is really all the diagnostics I have done so far...

  1. After successfully booting the target using the SD card boot method, I used Wireshark and saw that it seemingly should have worked (at least my host and board talk to each other)
    • My host responded to MNT with a status of "OK"
    • My host  responded to GETPORT with a good port (2049 in this case)
    • Next one I am not sure of... the protocol was NFS, the message to my host was "V3 NULL Call" and the response from the host was "V3 NULL Reply".. not sure what that means but being it was a reply, and no further attepmts were made, it seems like it should have worked.
  2. I did a ping test overnight, and only maybe 40 were lost out of thousands of pings (so the ping utility said 0% loss).  So it seems like the HW is okay, but then again ping is not too demanding of a task.

The biggest confusion I have is that the FTP always works (both in u-boot and when running Linux after an SD boot), and that NFS actually works on a rare occasion when done with u-boot.

 

Has anyone else had problems like this?  Any suggestions on what I can do to further troubleshoot?

 

Thanks!

 

- Matt

Outcomes