Wolfgang Wegner

Problems getting MCF5373L to run...

Discussion created by Wolfgang Wegner on Jan 29, 2007
Latest reply on Jan 31, 2007 by Wolfgang Wegner
Hi all,

I am having serious problems getting "my" MCF5373L to run.

My first (software) steps were with a Cobra5329 board as a development platform. There I used TBLCF BDM adaptor just for checking I could contact the processor because I did not want to touch the bootloader, but this worked.

Now we have a custom board with MCF5373L, DDR-SDRAM and a 16-Bit Flash, FlexBus is running on 1.8V. We have 6 Boards made, and only two of them even had a running crystal oscillator. One of them stopped operation shortly after, and even on the last one with working oscillator, I am not able to contact the processor using my TBLCF BDM adaptor.
With the "bdm-chk" utility from the m68k-bdm tools, I only get to the message "CSR break not set, target failed to break, CSR = 0x00000000" - this is more than without powering up the Coldfire, because in this case, the utility fails even earlier with "Reading CSR failed: Operation not permitted". This behaviour is the same with all boards, oscillator running or not.

All operating voltages are present and clean, reset is released. What puzzles me most is that on all the boards that are not running, the crystal oscillator pins are floating at around 3V, while being down below 1V when running. Changing the processor on the board that stopped working does not change anything.

The crystal is close to the balls, 18pF series resonant, I also tried changing capacitor values - it seems not to be a problem in this area. I double-checked all (supply, system control, data and BDM) pins according to the MCF5373RM Rev. 1. RCON is low, and D[98654321] == 00000100 is driven by a 74ALVC245 during reset (static behaviour also checked).

I am really out of ideas, so if anybody has hints what I could check and might be doing wrong, please let me know!

Best regards,
Wolfgang

Outcomes