Prachi Singhal

LTIB Installation Error

Discussion created by Prachi Singhal on May 30, 2011
Latest reply on Sep 2, 2011 by Eduardo Gorio

Hi,

 

I have started working on iMX51 EVK and started with following the steps to configure and install LTIB. I am following these two documentation for this:

 - http://www.freescale.com/files/dsp/doc/app_note/AN3875.pdf

 - http://secs.oakland.edu/~ganesan/iMX/i-mx-evk/installing-ltib/

 - ltib_build_host_setup.pdf from freescale website

 - imx51_evk_linux_bsp_userguide.pdf from freescale website

 

I am using Ubuntu 10.10 Virtual machine on VMware workstation. These are the series of steps that I followed:

1. Installing the dependencies packages

2. Downloading the LTIB source from Freescale's website

3. Editing sudoers file for permissions for LTIB

4. Changed directory permissions for LTIB directory (I was getting some permission related errors)

5. Executed ./ltib

 

I am getting the following error:

 

Processing deployment operations==================================

making filesystem image file

staging directory is /opt/freescale/ltib/rootfs.tmp

removing the boot directory and files

removing man files and directories

removing info files

removing /usr/share/locale directory

removing static libraries

find: pred.c:1932: launch: Assertion `starting_desc >= 0' failed.

Aborted

Died at ./ltib line 591, <> line 606.

traceback: main:591

Build Failed

 

 

Please help me regarding this error. I have tried to search about this online and even tried different patches for LTIB, but none seem to work so far.

I am counting on the expert's advice, please.

Outcomes