mukesh kumar

accessing UARTs/Serial Ports -blog archive

Discussion created by mukesh kumar on Mar 31, 2011

Hi Eric,

I am working on Android serial port application for sending and receiving data on serial port. I have downloaded your project and tried to run it on my machine. While doing so, I am facing few issues. I would really appreciate if you could help me solve these. The issues are mentioned below.

Development Environemnt:

Windows XP SP3; Eclipse Gallileo; Android 3.0;NDK5.0;

When I run this application and set the port ttyS0/S1 for data reading/writing; on ttyS1 I am getting object of File Descriptor in input Stream (may be garbage also). When I type something in emission text box, the data is written through output-stream but I don't get data on Serial port or even in receiver box of Console tab.

I have usb to serial port adaptor for checking  serial port data on another machine and I am trying to send the data from android emulator to serial port but I don't get data on that particular port.

Is there anything which I am missing while running the application? At present, I do not have any android phone with me to test the data. I would really appreciate if you could help me with this.

Thanks in advance,

 

 

 


 

 


Outcomes