Nicholas Cooke

Flashing the M52223EVB - Connection Problems

Discussion created by Nicholas Cooke on Jan 8, 2007
Latest reply on Sep 20, 2007 by JIM LAMBERSON
I have been trying for some time now with no success. I have tried flashing both Stationery built code as well as the CMX provided USB Mass Storage stuff to the M52223EVB (Rev B Board). I have religously followed (I think) the Targeting Coldfire (PDF) document.
 
Each time I try do an erase I get a message saying failed to write - error in connection. So I presume it can't be a badly built project cause the erase must happen before attmepting to load the Flash.
 
I then tried to use the Hardware Diagnostics option - I get:
 
" Connect Failed : Can't conenct to PE micro via USB "
 
There must be something simple that I am missing out on.
 
Does the J1 jumper of BDM_Config or JTAG have anything to do with this. I have tried both - same story.
 
All my code generated under Console Debug gets things like the PIT, ADC etc running quite nicely.
 
Maybe I have not read an important document prior to this??????
 
That tall building down the road looks like a good option - I am getting desparate.

Outcomes