Deepthi Kiran

YAFFS2 filesystem and UBIFS writing issue with IMX283 processor

Discussion created by Deepthi Kiran on Mar 14, 2011
Latest reply on Nov 7, 2012 by Fernando Luis

Hi,

  We are using linux-2.6.35 released BSP. We are trying to bring up YAFFS2 on that .We mounted YAFFS2 and copied files system on the mount directory, so much of bad blocks are getting created. We tried using nand-write command nandwrite –a –o /dev/mtd1 nand.yaffs2 then it is crashing and we are getting the following messages

  

bad block at d3e0000, 1 block(s) gpmi-nfc gpmi-nfc.0: This driver doesn't support

t writing the OOB

from d3e0000 will be ski------------[ cut here ]------------

pped

Writing data to blWARNING: at drivers/mtd/nand/gpmi-nfc/gpmi-nfc-mil.c:1014 mil_

ecc_write_oob+0x68/0xe8()

ock 1696 at offset 0xd40Modules linked in:0000

Bad block at d4000

00, 1 block(s) from d400Backtrace: 000 will be skipped

Wri

ting data to block 1697 [<c00354a8>] (dump_backtrace+0x0/0x114) from [<c0412fa0>

] (dump_stack+0x18/0x1c)

at offset 0xd420000

Bad r7:00000009 block at d420000, 1 blo r6:000003f6ck(s) from d420000 will  r5:c

0293e6cbe skipped

Writing data r4:00000000 to block 1698 at offset

 0xd440000

Bad block at[<c0412f88>] (dump_stack+0x0/0x1c) from [<c004d69c>] (warn_slowpath_

common+0x54/0x6c)

 d440000, 1 block(s) fro[<c004d648>] (warn_slowpath_common+0x0/0x6c) from [<c004

d6d8>] (warn_slowpath_null+0x24/0x2c)

m d440000 will be skipped r9:000e2880d

Writing data to block r8:0000000b 1699 at offset 0xd46000 r7:0001d7800

Bad block at d460000, r6:c0595ad0 1 block(s) from d460000 r5:c77a41e8 will be skipped

  Is there any patch for gpmi-nfc driver to support  this?

 We even tried with nandwrite –a –p /dev/mtd1 nand.yaffs2. It is showing as writing success, but if we mount the filesystem, we are able to see only lost+ found directory. We created .yaffs2 image by using mkyaffs2 utils.

We even tried with UBIFS, once it is getting attached and we could able mount and copy filesystem into it, but if we detach ubi and attach again the we are getting the following errors

UBI error: ubi_scan_add_used: two LEBs with same sequence number 4
ubiattach: error!: cannot attach mtd1
           error 22 (Invalid argument)

Along with this we even tried nand write in u-boot. We are getting the following error.

nand write 0x42000000 0 0x30000

NAND write: device 0 offset 0x0, size 0x30000

[send_page] DMA error

[send_page] DMA error

[send_page] DMA error

[send_page] DMA error

[send_page] DMA error

[send_page] DMA error

[send_page] DMA error

196608 bytes written: OK

As per the below mail post they are telling that nand driver is not ported for imx283 in the linux 2.6.35 BSP.  But in the reference manual it is told that gpmi-nfc is the driver for NAND. We need to get the proper clarification on this.  Please help us to resolve this issue as early as possible

http://www.spinics.net/lists/u-boot-v2/msg02497.html

Thanks and Regards

Deepthi

 

Outcomes