Lifeng Yang

CodeWarrior Command Line Assembler Questions

Discussion created by Lifeng Yang on Dec 22, 2006
Latest reply on Jan 18, 2007 by Lifeng Yang
Hello,
     I am new to this Forum. I have looked through most articles posted on the forum and hoped to find some answers that I need, but I failed. I decided to post some questions and hope some experts in this field may help me out.
I worked on a project that uses MCF5235 and the MetroWorks IDE. I am new to the CodeWarrior's tools but I am very familiar with Diab compiler. I am trying to port some code from Diab to CodeWarrior and I have encountered some problems. I got used to use the DOS style make file to compile and link all files in the project so I am sure what exactly the compiler is doing. I started with the MetroWorks's command line tools such as mwccmcf,exe, mwasmmcf.exe and mwldmcf.exe.
 
First, I set all necessary environmental variables and paths, then I tried to compile a assembly file use mwasmmcf.exe
 
Since I cannot find MCF5235 in the processor list, I used CF2.
 
ASM = mwasmmcf.exe
SFLAGS=-c -g -cwd proj -DDEBUG=1 -proc CF2 >asm.err
INCLUDE_FILES="$(INCLUDE_DIR)\b.inc"
"$(OBJDIR)\a.o" : $(SOURCE_DIR)\a.s $(INCLUDE_FILES)
       $(ASM) $(SFLAGS) $**
I got the following error message:

### mwasmmcf.exe Driver Warning:

# No file mapping matches 'include_dir\b.inc' (unrecognized file contents or

# filename extension); treating as source text

 

I tried different extension of b.inc, b.s, b.a and so on. I got the same message.

 

Any help will be appreciated.

Outcomes