Rob Savoye

EGL problems

Discussion created by Rob Savoye on Dec 21, 2010
Latest reply on Dec 22, 2010 by Rob Savoye

I'm trying to use the OpenVG support in L2.6.31_10.07.11_ER, and as far as I can tell, there is a bug in the lower level EGL support OpenVG depends on. ThIs is on a Freescale Babbage board. Basically eglInitialize() always returns a failure, yet the error code says success! If I force it to continue, it fails on the next EGL call, so it's definetely not initialized. The code I'm using runs on 3 other platforms, so I know it's not a code problem. Even eglinfo fails to initialize.

I'm now downloading the newer ltib sources from Freescale for L2.6.35_10.11.01_ER that I hope solves my problem. I figured it would be good to ask here, incase I'm just doing something stupid. I do have the amd_gpu_bin files installed, and the gpu driver is enabled in my kernel builds. I've also tried both the

gpu_z430 and gsl modules with no luck.

Outcomes