AnsweredAssumed Answered

QG8 debugging problems with OSBDM

Question asked by Jaromir Sukuba on Nov 22, 2006
Latest reply on Nov 23, 2006 by Jaromir Sukuba
Hello,
After successful test of OSMBDM with CW5.1 and RD16 part I ran into problems with QG8 device. First evening I spent searching why it doesn't work with QG8 at all, then I found 2K2 pull-up resistors are needed for both BKGD and RST lines (interesting it's not mentioned in datasheet, or I just can't find it - by the way, RD16 worked with schematic as in datasheet), then it finally started to work and I was able to debug and program it in application. After a few reprogramming device stopped to work as before. I captured screenshot to illustrate what happens when I press F5 and try to start debugger in OSBDM mode http://www.jednocipy.kvalitne.cz/a/bdm_problem_1.jpg On the other hand I can upload .s19 file into flash (I built just a small program to change state of port A to see some activity) selecting the properly s-record file http://www.jednocipy.kvalitne.cz/a/bdm_problem_2.jpg
Can somebody help me with this problem? Next week, when new QG8 parts arrive I'll test the new ones, but I'm afraid of getting into similar situation with them too.

Thanks,
Jarin

Outcomes