AnsweredAssumed Answered

Debugger shows no source, program counter wrong

Question asked by ROB LUND on Aug 25, 2006
Latest reply on Aug 25, 2006 by ROB LUND
I've got some code that works fine in a target board, but when I try to debug it, the debugger shows now source code. Also, the program counter is pointing to the wrong start address. The assembly window shows 0x0000 and a BRA *+2. This is a HCS908QG4 project.

I've got many other QG4 project directories that work fine in the debugger. I tried copying the working project BDM_P&E_Multilink_CyclonePro.ini files to the broken project. No go.

I tried copying the entire working project directory, moving just the source code files of the bad project, recompiling. Again, the bad debug behavior follows. Sounds like something in my source then, right? But again, this code seems to mostly work fine on its own in default user mode.

These threads are very close to my problem:

Thread #1

Thread #2

But I have the green bug column checked for all my C files, including the auto-generated startup C files.

Outcomes