Premji Chaudhari

CWv8.5 for LITE5200 rev.G board using BDI2000.

Discussion created by Premji Chaudhari on Jul 20, 2006
Latest reply on Feb 17, 2009 by Guest
Hi,
 
I am working on LITE5200 rev.G board using Codewarrior tools v8.5 and BDI2000 as debug interface device.I have updated my BDI2000's firmware to support MPC5200.

Then I started with stationary project as "debug version".This I did simply by pressing F7(make).Now my set up is ready as per below:

- BDI2000 is connected with CW-host using ethernet connection.

- targete board is connected with PC hyper-terminal using RS232.

Now if I pressed F5(for debug).I got i't log as per below:

BDI: 4C0 : BDI_Connect

BDI: : parameter = NETWORK 192.168.10.100

BDI: : BDI_Connect = 0

BDI: 4C0 : BDI_InfoGet

BDI: : bdiInfo.fwType = 11

BDI: : bdiInfo.fwVersion = 79

BDI: : bdiInfo.cpuType = 8a06

BDI: : bdiInfo.setupTimeStamp = 3e290000

BDI: : bdiInfo.setupId = ¿DLite5200 (16MB Flash, 64MB SDRAM)

BDI: : BDI_InfoGet = 0

BDI: 4C0 : BDI_TargetReset

BDI: : BDI_TargetReset = 0

BDI: 4C0 : BDI_MemoryWrite

BDI: : addr = 80000000

BDI: : space = 0

BDI: : count = 4

BDI: : data: (size = 4)

BDI: : 0000F000

BDI: : Abatron BDI Error: BDI: Invalid parameter

BDI: : BDI_MemoryWrite = -2102

BDI: 4C0 : BDI_Disconnect

BDI: : BDI_Disconnect = 0

Along with this log,one dialogue box come with:

"writemem error : writemem.I ox80000000 0x00f00000 failed"

Even I have set all setting in CW like remote debugging connection etc.

In BDI2000 side,I have selected config file for LITE5200.

Please do needful.

Any clue will be much apprecited.

regds,

Premji

 

 

 

Outcomes