MIKE YETSKO

Error in programming...

Discussion created by MIKE YETSKO on Jun 19, 2006
Latest reply on Jun 19, 2006 by MIKE YETSKO
I have a project that is Star12 based, and for the most part, it going great. I'm using a USB BDM Multilink pod to program the boards, and for a couple of hunder units, I've had only two problems.

I've had two units that fail with "Error while loading diagnostics to target system. The chip may be secured, or the derivative selected may be wrong"

One board was dead as built, and never made to work. The other board was one of my 'test' boards that I program and give to the shop to make sure I didn't put in any new bugs. It's worked for a long time and suddenly decided to go flakey. (That board also, once this started, sometimes gives an error that it fails to establish a communication speed.)

Now, the one board going bad I just placed aside, but this one was built up and up until failure worked fine. In fact, after it failed, I got it to reboot and it still had the OLD software loaded. Indicating it never got to erase.

Any ideas? Or is this just the cost of production?

Mike

Outcomes