Maria Gordon

MPC55xx: From CodeWarrior to WinIDEA

Discussion created by Maria Gordon on Jun 8, 2006
Latest reply on Dec 15, 2006 by Andrei Costache
Hi!
 
I'm compiling my project in CodeWarrior and want to run the application on my MPC5554 board through WinIDEA debugger. I don't seem to get this going though! The assembly instructions I get up in my WinIDEA (Isystem) window doesn't fit with the map file from my CodeWarrior project, ie the main instructions arn't where they should be according to the map file (actually, I can't find them at all). Has anybody tried to do this before and can give some hint?
 
 
To clearify what I've been doing:
  • I've activated in the CodeWarrior target an external debugger so that WinIDEA opens and downloads the file automoatically when I click on debug. Right now, I've just tried to get some Cookbook code running on the board.

 

  • I want to debug from SRAM. Therefore the emulator setting is set to start from 40000000h instead of BAM and I've added a .ini file to make up for it (same on as for the Gnu project that worked on my board).

 

  • When I single step, this seems to work fine, only the instructions are wrong.

 

  • When I run gnu projects accompanied with the WinIDEA everything works fine and the assembly file in the window makes sense.

I would be very happy for some help, I really need it...

/Maria

Message Edited by CrasyCat on 2007-04-13 11:21 AM

Outcomes