Malcolm Hartnell

CodeWarrior and interrupts

Discussion created by Malcolm Hartnell on Jun 5, 2006
Latest reply on Aug 23, 2006 by David Laban
I started using the 5474LITE board with a small program that I had written that communicated via RS232 using interrupts. This was downloaded into SDRAM using the resident dBUG program and worked fine.
 
I wanted to investigate using CodeWarrior and so started with the stationery for the CF_M5475EVB (C). After testing that it worked I added in all the files for my existing program and made any necessary changes for it work with the new compiler (such as using __declspec(interrupt) to indicate an interrupt routine). I eventually had a version that would compile using the UART SDRAM target and I downloaded it using the P&E cable (printer port version). I can single step through the program and it appears to work except for the interrupts. I took the S19 file that CodeWarrior produced and downloaded it via RS232 into dBUG and the program works correctly, interrupts and all. On searching the Help I found that I should have changed the CF Interrupt under Debugger in the Target Settings Panel but this doesn't seem to have any affect on the problem.
 
According to the About box, I am using CodeWarrior IDE version 5.7.0 Build 1984. When I click on Installed Products it tells me I am using CodeWarrior Development Studio for ColdFire Architectures Version 6.3 (Preview Release).
 
Can anybody tell me how to go about getting interrupts to work when using the debugger? I know the code is ok since it works when not using the CodeWarrior IDE so it must be something that the debugger is preventing.
 
Thanks,
Malcolm
 

Outcomes