Paul Bivol

twr-mcf51cn serial communication with freeRTOS

Discussion created by Paul Bivol on Apr 28, 2010
Latest reply on Apr 28, 2010 by Paul Bivol

Hi,

I'm quite new to microcontrolers and especially to the tower system. I tried on some demos featured on www.freescale.com and I have got myself into a pickle with Serial-to-Ethernet Bridge demo (AN3906). The problem is that I do not receive anything in hyperterminal from COM1.  I tried numerous configurations for the serial port with no luck. I tried starting only the vBasicSerialTerminal task:

xTaskCreate( vBasicSerialTerminal, (const signed portCHAR *)"UIF", TERMINAL_STACK_SPACE, NULL, TERMINAL_TASK_PRIORITY, NULL );

and even tried calling this function directly:

vBasicSerialTerminal("");

wich I modified to output the PROMPT string over and over:

set_printf_handle(handle_printf);

 for( ;; )
    {       
       /*This will run forever and ever*/  
           //wait();
           LED4_toggle();
           printf(PROMPT);
    }

 

I ran it with the debugger and it seems to get stuck in freeRTOS code somewere called by printf. 

I would like to mention that I use twr-mcf51cn and twr-ser with factory jumper configuration. Anyway, freescale's MQX example, telnet to serial bridge, works perfectly.

Can someone help me?

Outcomes